1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. BlueJayofEvil

    BlueJayofEvil

    Local Time:
    3:34 PM
    I've seen a few people have a similar issue before, but I'm not sure if this is the same. I'm on Linux (64-bit) and both Spoutcraft and vanilla Minecraft have this issue.
    Code (text):
    2012/07/06 14:43:33 [SEVERE] Exception in thread "Minecraft main thread"
    2012/07/06 14:43:33 [SEVERE] java.lang.UnsatisfiedLinkError: /home/aaron/.spoutcraft/bin/natives/liblwjgl.so: /home/aaron/.spoutcraft/bin/natives/liblwjgl.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
    2012/07/06 14:43:33 [SEVERE]    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    2012/07/06 14:43:33 [SEVERE]    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1924)
    2012/07/06 14:43:33 [SEVERE]    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1821)
    2012/07/06 14:43:33 [SEVERE]    at java.lang.Runtime.load0(Runtime.java:792)
    2012/07/06 14:43:33 [SEVERE]    at java.lang.System.load(System.java:1059)
    2012/07/06 14:43:33 [SEVERE]    at org.lwjgl.Sys$1.run(Sys.java:69)
    2012/07/06 14:43:33 [SEVERE]    at java.security.AccessController.doPrivileged(Native Method)
    2012/07/06 14:43:33 [SEVERE]    at org.lwjgl.Sys.doLoadLibrary(Sys.java:65)
    2012/07/06 14:43:33 [SEVERE]    at org.lwjgl.Sys.loadLibrary(Sys.java:81)
    2012/07/06 14:43:33 [SEVERE]    at org.lwjgl.Sys.<clinit>(Sys.java:98)
    2012/07/06 14:43:33 [SEVERE]    at org.lwjgl.opengl.Display.<clinit>(Display.java:132)
    2012/07/06 14:43:33 [SEVERE]    at net.minecraft.client.Minecraft.a(Minecraft.java:181)
    2012/07/06 14:43:33 [SEVERE]    at net.minecraft.client.Minecraft.run(Minecraft.java:600)
    2012/07/06 14:43:33 [SEVERE]    at java.lang.Thread.run(Thread.java:722)
    2012/07/06 14:43:48 [INFO] Exiting Spoutcraft Launcher
    I managed to get around this in vanilla Minecraft by updating the relevant LWJGL libraries to a 2.8.5 snapshot, but Spoutcraft insists on downgrading them the default version.
    I am using OpenJDK 7 (I've tried other Java versions - OpenJDK 6, Sun Java 6, etc) and had various issues with them as well.
    Is there a way to disable the auto-LWJGL-update?

    (I'm going to see if the latest update of Oracle Java fixes my issue, but I'm not holding my breath.)
  2. Wulfspider

    Wulfspider

    Local Time:
    4:34 PM
  3. BlueJayofEvil

    BlueJayofEvil

    Local Time:
    3:34 PM
    LOL oops. My bad. :oops:

    I do still have a question though - how do I disable the auto-update of the libraries?
  4. Wulfspider

    Wulfspider

    Local Time:
    4:34 PM
    You can't. You can disabling the md5 checking though as linked above.
  5. BlueJayofEvil

    BlueJayofEvil

    Local Time:
    3:34 PM
    Alright. It's solved. :)

Share This Page